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1. Introduction and Overview

This document will provide you with an overview of Inova LightLink™ Log
Viewer and the procedures for utilizing the options within Log Viewer.

Log Viewer allows you to see the contents of error log files and to obtain
diagnostic information for record streams. With Log Viewer you can:

e Display Diagnostic information and error logs for the various subsystems
of Inova LightLink. This information is displayed as an Inova LightLink
Diagnostic Log. (See Figure 1.)

e Set up a Remote View of logs on the Inova LightLink Core Server or on
any other LightLink machine that is running i_uls.exe, the unified logging
subsystem.
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Figure 1
1.12. Accessing Log Viewer
You can access the Log Viewer through one of these paths:

e Administrator > Log Viewer S icon
e System Manager > Tools > Log Viewer
e Start > All Programs > Inova LightLink > Tools > Log Viewer

Once Log Viewer is open, the main screen will look like Figure 2.
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Figure 2
1.2. Usingthe Log Viewer Icons
You can use Log Viewer to select and display two types of Diagnostic Logs:
Streams or Log Files.

The Log Viewer main window has two panes.

e Use the Log Chooser in the left-hand pane of Log Viewer to select the
Diagnostic Log(s) you wish to display.

e When you double-click on a Diagnostic Log, its data is displayed in Log
Viewer's right-hand pane, in a separate window (Figure 3).

¥ Inova Log Viewer - Stream: ContentSync... E|@|[z|

BroadcastClient.log A/
[ check_key_for_encrypl——
[ checklightlinkconnectior
cms_defaulter.log
! |ContentSyncManager.Iog |
[ contentSyncManager.|
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B datalink.log |
< )| @l
Inova Lightlink Ready CAP |[INUM | SCRL | .:

Figure 3

Every Stream will have a corresponding Log File by the same name, but the reverse is not
necessarily true. Some Log Files may not have matching Streams.
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1.2.1. Streams

8 datadilos Thig is 5 Stream. The icon indicates an active, "live" view of server or
client activities.

The window for a Stream is continuously updated with new log entries as they
become available. Streams may contain a maximum of 128K before they are
truncated. When an Inova LightLink application is closed, its streams are closed.

1.2.2. LogFiles

B datadilog Thjs is a Log File. The icon indicates a diagnostic file that is stored in
the Inova LightLink Logs directory.

The window for a Log File is not updated automatically, but a more up-to-date
view of the file can be acquired by closing and re-opening the window. Log Files
may grow to 1.2M before truncation occurs.

1.3. Selecting from the Log Chooser

Once you have determined the Log File or Stream you wish to display, double-
click on its icon on the Log Chooser to bring up the window associated with that
Log File or Stream.

The Log Chooser displays an icon for each Log File or Stream present at the time
Log Viewer is invoked (Figure 4).
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i Local Host Diagnostics % X atlinkconnection.log
f i BroadcastClient.log |
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Figure 4
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2. Using Find
2.1. Finding Specific Text

Follow these steps to use the find specific text in Log Viewer:

1. Choose Edit > Find or Hold down the CTRL key and press F. The Text
Search dialog appears (Figure 5).

Seek: I

I~ CaseSensiive | ReverseSearch [ Feqular Expression

Cancel

Figure 5
a. Click to mark the Case Sensitive setting if you want to specify
upper-/lowercase for your search (e.g., find "Exit" and not "exit").

b. Click to mark Reverse Search if you are at the bottom of a file or
want to change the direction of the search.

c. Type in the text you wish to locate.

2. Click Next to continue. Click Cancel to stop the Text Search feature.
When Log Viewer finds the last matching text and tries to search again, the Help:
No topics found dialog appears.

2.2. Finding Again

If you wish to use Find again, you can either choose Edit > Find Again or you
can just press the F3 button.

Log Viewer remembers the text you entered during the previous search. Press
F3 to repeat the text search as often as necessary.

2.3. Reversing the direction of search

To reverse the direction of the search, you can either choose Edit > Find or you
can hold down the CTRL key and press F.

When the Text Search dialog appears, Log Viewer remembers the text you
entered during the previous search.

Click to mark the Reverse Search setting and click Next to continue.
To search through a long file with many expected text matches, you can hold

down the F3 key to move rapidly from match to match.

All claims and information in this document are based on information publicly available at time of printing.
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3. Using the Stream View

To view a stream in Log Viewer, choose View | Stream View to make Streams
visible in Log Chooser.

All Streams will be shown.

To hide all Streams, choose View | Stream View to remove the check mark and
disable this option.

3.12. Viewing a Stream

Choose File > View Stream.

On the Stream Name dialog box (Figure 6), enter the name of the stream and
then click OK.

Please enter a stream name to load: @

I oK I Cancel |

Figure 6

The diagnostic view window for the Stream File appears (Figure 7).
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mﬁal. Hos,t..Di.agn---. 2 x Stream: datalink.lgg,_] 4P X
- i BroadcastClient, & |
B check _key_Ffor_¢—
| checklightlinkcon
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Figure 7
3.2. Saving a Stream

Choose File > Save As.

On the Log Viewer Save As dialog box, enter a file name and click Save to save
the stream.

All claims and information in this document are based on information publicly available at time of printing.
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3.3. Printing a Stream
1. Double-click on the desired Stream on the Log Chooser to bring up its
window.

2. Choose File > Print or click Print on the toolbar. The standard Windows
print dialog appears. You may print only one Stream at a time.

3. Adjust print properties (copies, orientation, etc) as needed.
4. Send the output to the printer as you normally do.

Caution: These files may be quite large when printed.
3.4. Setting Filters

When you right click on a stream file view and then right-click, a menu appears
that allows you to set the filters for the stream file (Figure 8).

=]
: Local Host Diagnostics
i I i_auditserver.log
B i_bus_server.log
B i_bus_serve—
% i_cefloon.lo Open s
. i_cefloon.lo Load Again
B i_client_mgr  JaveAs
i . i_client_mgr Flush File
- i_coalescer.log
: g i_ddsrv.log

Figure 8

You will have the following options on the right-click menu for the highlighted
stream file view:

e Open: Allows you to open the highlighted stream file

e Load again: Shows the log view information again for the selected stream
file

e Saveas: Allows you to save the file by a choosing a new and different file
name

o Flush file: Shows the log view for the selected stream file as empty

All claims and information in this document are based on information publicly available at time of printing.
All other product or service names mentioned in this document may be trademarks of the companies with which they are associated.
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4. Remote Log Viewing

Remote Log Viewing allows a LightLink User to check the status of other
LightLink-enabled machines in the enterprise. All of the Log Files and Streams
associated with a Remote Host can be viewed via Log Viewer.

4.1. Adding a Remote Host

Choose File > Add Host.

On the Hostname window (Figure 9), enter the hostname or IP Address of the
computer to which you want to connect and then click OK.

Please enter a hostname to connect to: @

I oK I Cancel |

Figure 9

If the i_ULS.exe is running on the target machine, the hostname and its
associated Log Files appear in the Log Chooser in the left-hand pane of the Log
Viewer.

4.2. Deleting a Remote Host

1. Highlight the hostname to be deleted from the Log Chooser.
2. Choose File > Remove Host.

On the Hostname window, enter the hostname or IP address of the
computer that you wish to remove and then click OK.

In the left-hand pane of the Log Viewer, the hostname and its associated
Log Files and Streams are deleted from the Log Chooser.

All claims and information in this document are based on information publicly available at time of printing.
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5. Viewing the Log File

To show All Log Files in the Inova LightLink Logs directory, choose View > Log
File View to make Log Files visible in the Log Chooser.

To hide all Log Files, choose View > Log File View to remove the check mark and
disable this option.

5.1. Openinga Log File

Choose File > Open Log File or click Open on the Log Viewer toolbar. On the
Open window (Figure 10), select the desired Log File from the list. You can
either click the Open button or double-click on the file name.

Open @
Look in: [E) logs -] « ek B3~
(ydsm [Zi_client_mar.log [ temim.log
Socm [2i_coalescer.log i log
My Recent await_app_exit.log [2i_ddsrv.log local_system_eve
Documents  [F9g, o gcastclint.log EJi_ext_imlog [metaom.log
@ check_key_for_encryption.log i_inputmanager.log msgedit.log
- [ checkiightlinkconnection.log i_launcher.log [ msglink.log
Desktop %9 cus_defauiter.log i_odms.log [ ocm_ui_db.log
[ contentsyncanager.log  [Ji_product_updater.log [ odms_setup.log
[ datadirectorysetup.log [Zi_site_monitor.log output_manager.
My D’ocumen\s ] datalink.log i_sublauncher.log ProductUpdateM
[ dsms_setup.log Ji_uls.log [ runtime _issues.lo
get_license_key.log installation_report.log securitymanager.,
[2i_auditserver.log [ _controller.log [E3sm_replication_ag
W5 Eofiuted [i_bus_server.log [launcher registrations.log [ smaddu.log
[Ei_cefloon.log [Eadmin.log [Esminstall.log
" ] <) | 3
My Network  File name: | ~| Open I
Places
Files of type: |ULS Log Files *log) =l Cancel
.
Figure 10

Any Diagnostic Log can be opened here, but the Log Chooser only shows files that reside
in the Inova LightLink Logs directory.

The Log File appears in its own diagnostic window, in the right-hand pane of the
Log Viewer (Figure 11).

nova Log Viewer - File: C:\Program File... g@

~ g

2 X mFiles\LightLinkil..| ¢ P X},

~|d BroadcastClient.log A
i = check_key_For_encrypl—
I8 checKlightlinkconnectior o -
B cms_defaulter.log B FL... g@@
ContentSyncManager.| Aug 22 20686 1:
[ ContentSyncManager.| Aug 22 2806 1:
] datadirectorysetup.log
B datalink.log v

} Local Host Diagnostics
AN,

i‘ 2.

i; i 1] il l\ o —
Inova LightLink Log Chooser Window CAP INUM [SCRL | .
Figure 11

Resize the Log Viewer and the Log File window to see as much of the file as you
require.
All claims and information in this document are based on information publicly available at time of printing.
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5.2. SavingalogFile

Choose File > Save As.

On the Save As window, enter a file name and click Save to save the Log File.
5.3. Printing a Log File
1. Highlight the desired Log File on the Log Chooser and double-click to

open its window.

2. Choose File > Print or click Print on the toolbar. The standard Windows
print dialog appears. You may print only one Log File at a time.

3. Adjust print properties (copies, orientation, etc) as needed.
4. Send the output to the printer as you normally do.
Caution: These files may be quite large when printed.

All claims and information in this document are based on information publicly available at time of printing.
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6. Log Viewer Menu Options

Fi

~u

=

le Menu

File | Edit Wiew ‘Window Help

View Skreamn
Open LogFile. .. Chrl+O
Save fs...

Close

Add Host
Delete Host

&b print... Chr+p

Prink Prewview

Prink Setup...

1 await_app_exit.log

2 BroadcastClient.log
30OCM_1_Inova_TCP_IP_Displays.log

4 OCM_5_Database_Publisher _Output.log
5 OCM_4_aMS_LED_Displays.log

Exit

e View Stream: Open a dialog to select a Stream by typing
in its name

¢ Open Log File: Open an existing Log File

e Save As: Save the file by a specified file name

e Close: Close the current file

e Add Host: Add a Remote Host to the Log Viewer tree

e Delete Host: Remove a Remote Host from the Log
Viewer tree

e Print: Print the current file

e Print Preview: Display a thumbnail print view of the
Log File or Stream

e Print Setup: Access the print dialog for network and
local printers

o List of Files: Provide a list of recently accessed Log Files
and Streams

e Exit: Exit the Log Viewer

View Menu

=

CRICE]

jew | window  Help

Standard

Log Chooser

Stream View

Log File View

ULS Stakus

e Standard: Log Viewer Toolbar and buttons
¢ Log Chooser: Log Chooser

e Stream View: All Streams

e Log File View: All Log Files

e ULS Status: Unified Logging Subsystem (ULS) status
window

All claims and information in this document are based on information publicly available at time of printing.
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Edit Menu* e Undo: Undo the most recent action taken
Edit | Yiew ‘Window e Cut: Copy text to the Windows clipboard, removing it
Undo ctrhz from the Log Viewer Log File window
; S cut Sl e Copy: Copy text to the Windows clipboard, leaving it in
g Copy  Ctri+c i place in the Log File window
[ Paste  Chrlev f e Paste: Copy text from the Windows clipboard to the
| [ Py P
@ B colr current cursor location in the Log Viewer Log File
I - window
l Find Again  F3
e Find: Enter text for search for in the file
e Find Again: Press F3 or choose this option to repeat the
identical previous text search
Help Menu e Log Viewer Help: Start at the beginning with the

ek | Introduction to On-line Help for Log Viewer

R LogViewerHelp  F1 e Help Index: Access the Index for quick location of
procedure- or command-specific help

Help Inde:x

Help Search e Help Search: Access the Search option for quick location
of procedure or command-specific help

Inowva Home Page

about Log Yiewer e Inova Home Page: Access the Inova website and FAQ

e About Log Viewer: Access copyright information and
Inova Development Team credits

Window Menu* e Cascade: Stack the open windows one behind the other,
indon |t slightly overlapping
Cascade
T e Tile: Display the open windows, sized to all fit in the
artange feens main window and touching edges at top, bottom, and
1 File: C:\Program FilesiLightLinkilogst checklightlinkconnection.log . . ey .
£ File: C:\Program FilesiLightLinkilogs|datadirectorysetup. log Slde/ as Wlth Cellmg or ﬂoor tlles
3 File: C:\Program FilesiLightLinkilogs!await_app_exit.log

e Arrange Icons: Cause any "stray" minimized window
icons to form rows at the bottom of the main window

e [Current File List]: Display the titles of all Log Viewer
windows that are currently open. The check box will
indicate the most recently opened file.

*Under some operating systems, this menu is only visible when there is a window
displayed in the right-hand panel of Log Viewer.
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