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1. Introduction to Data Field Expression  

In Inova LightLink®, the Data Field Properties dialog provides you with an interface for 
viewing or modifying Data Field Formatting Attributes and Data Field 
Thresholds.  Once the Data Field Expressions are created, then you can insert into your 
message using your specified criteria.  Inova LightLink components that support Data 
Field Expressions are Message Editor, Broadcaster Designer, TaskLink, and DataLink.   

1.1. Data Field Expression Dialog 

The Data Field Expression dialog allows you to modify the expression that you have 
specified. It will perform necessary validation to ensure that thresholds are defined in a 
contiguous, ascending set of values appropriate to the data fields’ type and will allow 
all threshold-specific formatting options specified in the DataFieldThreshold.  The Data 
Field Expression dialog presents a hierarchical list of data fields, organized by Data 
Source and Data Field Group.  It will be populated from Data Field information in the 
Data Directory.   

The Data Item Selection Dialog is also part of the Data Field Expression Dialog 
Library.  It uses the same underlying tree structure, but does not support 
expressions.  It supports the display and selection of a single Data Source, Data Group, 
or Data Field.  

 

Figure 1 

1.2. Process Overview 

To insert a data field, you will follow the process below.  Refer to the following sections 
for more details on each step. 

1. Insert the data field. 

2. Format the properties of the data field. 

3. Create a data field expression. 

4. Add threshold to the data field expression. 
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2. Inserting a Data Field  

To insert a data field into a LightLink message, decide which statistic you want to 
display and then select each statistic for insertion into your messages. The value in the 
Data Field is continuously updated by the Inova LightLink System when the message is 
displayed. 

The following steps detail how to insert a Data Field into a LightLink message: 

1. Place the cursor where you want the data to appear. 

2. Select Insert > Data Field. The Data Field Expression dialog appears (Figure 2). 

 

Figure 2 

3. Click on the Inova LightLink System Tree to display the data source connections 
available. 

• Click on the + node of a data source connection to show the System Groups. 

• Click on the + node of a System Group to see the Data Fields available. 

4. Highlight the desired field and click Apply to insert the field. 

5. If you are simply inserting a data field, click Close to dismiss the Data Field 
Expression dialog.  If you wish to format the data field, refer to Section 3. 

In the application, the Data Field will appear in the message as a series of asterisks. 
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3. Formatting the Properties of a Data Field 

The following details how to use the Format tab options for a Data Field.     

1.  After you have selected a data field and clicked Apply, then select Properties.  The 
Data Field Properties dialog for that Data Field appears.  

2. Select the Format tab. 

3. Complete the Data Field Properties options for the descriptions below. 

• Type - Displays the format type of the Data Field selected (read only). 

• Alignment - Specifies the alignment of the Data Field as it increases or 
decreases.  Your options are to at the align left, right, or center of the width 
(selected below). 

• Format – Changes the format of the data value. Choose from the drop-down 
menu. 

• Width - Specifies the maximum number of spaces the field value should 
occupy in any message. 

If you select a Data Field Width that is not wide enough, Inova LightLink will 
display the pound sign at run time for each overflow "digit" of the Data Field 
value.  

4. Select OK to accept the configurations. 
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4. Creating a Data Field Expression 

4.1. Rules for Data Expression Syntax 

Expressions are composed of elements, operators, and functions using standard 
algebraic notation and precedence.  Refer to Table 1 for examples of how elements will 
be interpreted by the Data Field Expression dialog. 

Sample Element Interpretation 

542 INT32 
7654000  INT32 

2.5  DOUBLE 

“Rabbit” STRING 

"5:00:00"  TIME or STRING, depending on context 

"9/22/02 3:15:00 AM" DATETIME or STRING, depending on context 

[Calls Waiting]  The name of the data field for Calls Waiting 

true  BOOLEAN 

false  BOOLEAN 
Table 1 

When composing a data field expression, remember these hints: 

• The Data Field Expression dialog will only use INT32 when defining integers. 

• Quoted strings are interpreted as TIME or DATETIME when used with an 
operator or function that requires one of these types. 

• TIME can represent either a time of day or a quantity of time. Therefore 
"5:00:00" could mean "five hours" or it could mean "five o'clock AM." The 
interpretation depends on the operator or function with which it is used. 

• The data field name must match a data field that is defined in the system.  

• Each expression and sub-expression has a resulting type that is one of the 
Inova LightLink data field types. 

• The type requirements and results for the operators is as follows: 

Following are the operator types allowed on left and right side Result type: 

• Comparison STRING and STRING   BOOLEAN 

• NT and INT 

• INT and DOUBLE 

• TIME and TIME 

• DATE and DATE 
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• DATETIME and DATETIME 

• TIME and DATETIME - (Only the TIME component of the DATETIME is 
compared) 

• DATE and DATETIME - (Only the DATE component of the DATETIME is 
compared) 

• Logical BOOLEAN and BOOLEAN   BOOLEAN 

• Arithmetic INT and INT     INT  

• INT and DOUBLE    DOUBLE 

4.2. Tools for Creating Data Field Expressions 

4.2.1. Keypad  

You can see the keypad by selecting the More tab on the Data Field Expression Dialog.  
The keypad is located on the expandable window of the Data Field Expression dialog 
(Figure 3).  

 

Figure 3 

The keypad allows you to choose numbers 0-9 to be manipulated with the Comparison 
Operators, Arithmetic Operators, Logical Functions and Other Functions. The Keypad 
includes the numbers 0 through 9 and the decimal point.  

4.2.2. Arithmetic Operators 

The Operators and Function for the Data Field Expression are symbols which allow you 
to set the criteria with the function keys.  These are located on the The LightLink 
Database folders and the files within those folders should also be excluded from 
antivirus scans. Refer to Table 2 for a list of these folders and files.  Note that Error! 
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Reference source not found. expandable window of the Data Field Expression dialog 
(Figure 4).  Expressions are built up by combining simpler sub-expressions with 
operators.  

 

Figure 4 

For example: 

• 2 + 2 is a simple expression having only one operator. 

• 2 + 2 + 5 is a more complex expression consisting of the sub-expression 2 + 2 
combined with the element 5 via operator +. 

4.2.3. Descriptions of Elements 

An element is part of the symbols for arithmetic functions that allow you to set the 
criteria for the data field.  Elements correspond with specific Inova LightLink data field 
types.  Refer to Table 2 for the elements and their corresponding descriptions and data 
field types. 

Element Description Data Field Type 

Integer A whole number with an optional 
minus sign. 

INT16, INT32, 
UINT16, UINT32 

Floating point 
number 

A number that includes places after the 
decimal point or scientific notation. 

DOUBLE 

Quoted string A sequence of characters enclosed in 
"double quotes". 

STRING, DATE, 
TIME, DATETIME 

Data field name The full name of a data field in the 
system, enclosed in [square brackets]. 

Any type; depends 
on the data source 

Boolean value  Data with a true or false value.  True or False 
Boolean 

Table 2 
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4.2.4. Descriptions of Logical Operators 

Refer to Table 3 for descriptions of the logical operator functions. 

Function Description 

 

Beginning parentheses to be used with ending parentheses to set 
the priority of the equation. 

 
Ending parentheses to be used with beginning parentheses to set 
the priority of the equation. 

 
AND returns TRUE if both inputs are TRUE (if 'this' AND 'that' are 
true). The AND operator is evaluated before the OR operator. 

For example: 

• (1) AND (0) would evaluate to zero because one input is false.   

• (1) AND (1) evaluates to 1.  

• (any number but 0) AND (0) evaluates to 0.   

 

For an OR statement, if either (or both) of the two values it checks 
are TRUE then it returns TRUE. OR will be evaluated after AND. 

For example: 

• (1) OR (0) evaluates to 1.  

• (0) OR (0) evaluates to 0.  

 
The NOT operator accepts one input. If that input is TRUE, it 
returns FALSE, and if that input is FALSE, it returns TRUE. NOT is 
evaluated prior to both AND and OR. 

For example: 

• NOT (1) evaluates to 0, and NOT (0) evaluates to 1.  

• NOT (any number but zero) evaluates to 0.  
Table 3 
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4.2.5. Descriptions of Other Functions 

The Other Functions are accessible through a drop down tab on the Data Field 
Expression dialog.  Refer to Table 4 for further details about the other functions. 

Function Description Examples 

BLANK (str) Returns true when 
the string passed in is 
empty.  
 

• BLANK ("") returns true. 

• BLANK ("Hello") returns false. 

• BLANK([Output Device Status::SRV:1 
CHN:1 DSP:1]) would return true only if 
the data field evaluated to "". 

CONTAINS 
(str, substr) 

Returns true when 
the string passed in 
as the first parameter 
contains the 
substring passed in 
as the second 
parameter anywhere 
within the string. 

• CONTAINS ("INOVA Corporation", 
"Corp") returns true. 

• CONTAINS ("INOVA Corporation", 
"Hello") returns false. 

• CONTAINS ([Output Device Status::SRV:1 
CHN:1 DSP:1], "nect") would return true if 
the data field evaluated to "Connected". 

BEGINS 
(str, substr) 

Returns true when 
the string passed in 
as the first parameter 
begins with the 
substring passed in 
as the second 
parameter. 

• BEGINS ("INOVA Corporation", 
"INOVA") returns true. 

• BEGINS ("INOVA Corporation", "Corp") 
returns false. 

• BEGINS ([Output Device Status::SRV:1 
CHN:1 DSP:1], "Conn") would return true 
if the data field evaluated to "Connected". 

YEAR(date), 
DAY(date) , 
HOURS (time), 
MNUTES (time), 
SECONDS 
(time)     

Parses date or time 
fields. 
 

• The following "if condition" could be used 
to schedule a birthday message to play on 
April 18th:  (MONTH([System 
Fields::System Date/Time]) = 4) AND 
(DAY([System Fields::System Date/Time]) 
= 18)  

Table 4 
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5. Assigning Threshold Values to a Data Field 

The following details how to assign threshold values to a data field.  Any thresholds 
you define here will be saved as the default thresholds to be used whenever this Data 
Field appears in an Inova LightLink application.   

When setting up your system, you may want to select Data Fields and determine their 
thresholds before you include the Data Fields in your messages or DataLink views. 

The advantage to this method is that the threshold values selected from this dialog are 
saved with the Data Field until you decide to edit them, thus eliminating the need to 
define threshold values and settings with each new instance of the Data Field.   

To access the thresholds, click the Thresholds tab on the Data Field Properties dialog 
(Figure 5); note that the Thresholds tab will look slightly different depending on which 
application you are using.   

 

Figure 5 

To modify the thresholds, enter the values in ascending order for this Data Field, 
selecting the color each time.  Generally, users prefer to apply these colors: 

• Green – for fields within an acceptable range.     

• Yellow - for fields bordering an unacceptable range and may need attention. 

• Blinking Red – for fields in an unacceptable range.   

Note that for threshold notifications to work properly, you must enter the values in ascending 
order. 
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Appendix A. Sample Data Field Expressions 

The following displays examples of Data Field Expressions for Inova LightLink. 

A1. Example of a Time Zone in Data Field Expression 

This example shows time offset to Pacific Time on the display in an Eastern Time Zone 
using Inova LightLink Message Editor. 

1. Select Message Editor > Insert a Data Field. The Data Field Expression dialog 
appears (Figure 6). 

 

Figure 6 

2. Select a Data Field.  In this example, select the [Realtime] ACD Time under 
System Fields. 

3. Click the Select button. 

4. This Selection appears in the Expression pane:  [System Fields::ACD Time]. 

5. Use the Minus symbol from the Arithmetic Operators to create a hyphen. 

6. Type in the time to which you want to convert.  You must use the quotation marks 
around the time. To present time as a data field:   

• " 00:00:00" shows hour:minutes:seconds. 

• "00:00" shows minutes and seconds. 
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• "00" shows seconds. 

To convert time zones: 

• Atlantic Time - Add 1 hour from the current Eastern Time 

• Central Time  - Subtract 1 hour from the current Eastern Time 

• Mountain Time - Subtract 2 hours from the current Eastern Time 

• Pacific Time - Subtract 3 hours from the current Eastern Time 

• Alaska Time - Subtract 4 hours from the current Eastern Time 

• Hawaii Time - Subtract 5 hours from the current Eastern Time 

• United Kingdom - Add 6 hours to the current Eastern Time   

7. When you are finished, click Apply to add this to your message.  Select Save to 
keep this expression. 

Once you have created this expression, you can add it to display in your message.  

A2. Example of a Threshold in Data Field Expression 

This example shows a Threshold for the oldest call waiting using Inova Solutions 
LightLink Message Editor.  

1. Select Message Editor >  File > Schedule. 

2. The Schedule dialog appears (Figure 7).  Select the Durations tab. 

 

Figure 7 



LightLink Data Field Expression  
Solution Guide 

 

All claims and information in this document are based on information publicly available at time of printing.  
All other product or service names mentioned in this document may be trademarks of the companies with which they are associated.  

© 2021 Inova Solutions  |  All rights reserved  |  page 12 

3. Select If... button.  The Data Field Expression dialog appears.  

4. Enter your data field expression as shown in the steps above.  Below is the 
incorrect way to write a threshold for a time field keying on 1 minute: 

[Split Report:SALES:Oldest Call Waiting] > 60 

The expression is written with the call waiting as 60, which is incorrect because it 
does not have the quotation marks around the number to convert it to time.     

5. The Check Failed dialog appears.   Click OK.  

6. Reenter the correct expression, with quotation marks to indicate time.  Below 
shows the correct way to write a threshold for a time field keying on 1 minute: 

[Split Report:SALES:Oldest Call Waiting] > “60” 

--OR-- 

[Split Report:SALES:Oldest Call Waiting] > “0:01:00” 

 

A3. Additional Data Field Expressions 

Below are some additional sample data field expressions: 

Total Service Factor  

((([Application:TECH:Total Calls Answered] + 

[Application:TECH:Total Calls Abandoned]) - 

([Application:TECH:Calls Answered After Thresh] + 

[Application:TECH:Calls Abandoned After Thresh])) / 

([Application:TECH:Total Calls Answered] + 

[Application:TECH:Total Calls Abandoned])) * 100 

 

ASA 

 ((Calls Answered Skillset Delay /  Total Calls Answered) 
+.001) + .5 

This calculation does the calculation if the value is 0 (+ .001) And rounds to the next 

highest integer (+ .5) 

 

Abandoned  

((Calls Answered – Calls answered after threshold) * 100 ) / 

Calls Answered 
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Appendix B – Available Functions 

The available data analysis functions are listed in Table 5.  

Function Purpose Usage 

AVERAGE Returns the average of a series of 
numbers. *  

AVERAGE(Num1, Num2, Num3, … as 
double; Num as Integer) as  
double  
 

DAY Returns the day given a date value. DAY (date) as integer  
 

HOURS Returns the hours given a time value. HOURS (time) as integer  
 

MAX Returns the Maximum value from a 
series of numbers. *  

MAX(Num1, Num2, Num3, … as 
double; Num as Integer) as double  
 

MIN Returns the Minimum value from a 
series of numbers. 

MIN(Num1, Num2, Num3, … as 
double; Num as Integer) as double  

MINUTES Returns the minutes given a time 
value. 

MINUTES (time) as integer 

MONTH Returns the month given a date value. MONTH (date) as integer 
SECONDS Returns the seconds a time value. SECONDS (time) as integer  

 
TOTAL 
SECONDS 

Returns the given time in total 
seconds. 

TOTAL SECONDS (time) as integer  
 

YEAR Returns the year given a date value. YEAR (date) as integer  
 

Table 5 

*Num is the number of numbers in the call and must be from 0 to 1024. 

 


